Kalendár udalostí

Predchádzajúci mesiac Nasledujúci mesiac
December 2019
Po Ut St Št Pi So Ne
      1
2345678
9101112131415
16171819202122
23242526272829
3031     

Chyba PHP knižnice pre vytváranie PDF

22.03.2019, 08:59


Bezpečnostný výskumník objavil závažnú chybu v populárnej PHP knižnici, ktorá útočníkom umožňuje vzdialené vykonanie kódu na web stránkach a webových aplikáciách využívajúce TCPDF knižnicu. Útočník tak môže spustiť škodlivý kód a potenciálne prevziať kontrolu nad týmito systémami. Nová verzia chyby známej od augusta 2018 ovplyvňuje TCPDF – bežná PHP knižnica používaná pri konvertovaní HTML kódu do PDF súborov. Používateľom je odporúčané vykonať aktualizáciu TCPDF na verziu 6.2.22 a vyššiu.


Tagy:Správa
Kľúčové slová: PDF, PHP, library, TCPDF, remote code execution
Zdroje: https://www.zdnet.com/article/severe-security-bug-found-in-popular-php-library-for-creating-pdf-files/

Skočiť na menu